We are continuing to monitor the affected environments for any further issues
Posted May 07, 2026 - 17:56 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 07, 2026 - 15:48 PDT
Update
We are currently investigating an issue affecting tenant accessibility in the test.reltio.com & dev.reltio.com environment (AWS us-east-1). Some customers may be unable to access their tenants through the UI or API at this time.
Our team is actively working to restore normal access as quickly as possible. We will provide additional updates as more information becomes available.
Posted May 07, 2026 - 15:00 PDT
Investigating
We are currently investigating reports that test.reltio.com is currently having an outage.
Our engineers are working to resolve the issue and will provide another update shortly.
Posted May 07, 2026 - 14:35 PDT
This incident affected: US Cloud (UI, API, Dataload).