HIPAA environments are facing performance degradation.

Incident Report for Reltio

Resolved

The incident has been resolved.
Posted Jul 11, 2025 - 09:34 PDT

Monitoring

A fix has been implemented, and we are monitoring the result.
Posted Jul 11, 2025 - 09:29 PDT

Investigating

We are presently encountering performance degradation within the HIPAA environment. We are actively investigating the matter and will provide updates at regular intervals.
Posted Jul 11, 2025 - 09:12 PDT
This incident affected: US Healthcare Cloud (UI, API).