RDM Lookups are not accessible

Incident Report for Reltio

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 12:47 PDT

Monitoring

Greetings!

RDM lookup is now accessible. Our team will continue to closely monitor the situation to ensure stability. We will share further updates if there are any new developments.

Regards,
Reltio Team
Posted Apr 15, 2026 - 10:14 PDT

Identified

Greetings!

RDM lookup is not accessible. Team has identified the issue and working towards resolving it. We will update the status as soon as we have more details to share.

Regards,
Reltio Team
Posted Apr 15, 2026 - 10:04 PDT

Update

We are continuing to investigate this issue.
Posted Apr 15, 2026 - 09:51 PDT

Investigating

Greetings!

We have identified that RDM lookup is not accessible. The team has already started the investigation on identifying the root cause. We will update the status as soon as we have more details to share.

Reagrds,
Reltio Team
Posted Apr 15, 2026 - 09:49 PDT
This incident affected: US Cloud (Reference Data Management (RDM) Service), US Healthcare Cloud (Reference Data Management (RDM) Service), Asia Pacific Cloud (Reference Data Management (RDM) Service), Canada Cloud (Reference Data Management (RDM) Service), United Kingdom Cloud (Reference Data Management (RDM) Service), and US Financial Services Cloud (Reference Data Management (RDM) Service).