Reltio Console UI – Partial Outage

Incident Report for Reltio

Resolved

The incident has been resolved. The Console UI is now functioning as expected. All affected components have been verified, and normal operations have resumed.
Posted Oct 18, 2025 - 18:53 PDT

Monitoring

The Reltio Console UI issue has been resolved, and full functionality has been restored.

Our team will continue to monitor the scenarios closely to ensure stability and confirm sustained performance.
Posted Oct 18, 2025 - 17:13 PDT

Update

Our teams are actively collaborating with our cloud service provider to identify the root cause of the Reltio Console UI issue and restore full functionality.

At this time, Console API services remain fully operational and are not impacted.

We will provide the next update within 30 minutes, or sooner if new information becomes available.
Posted Oct 18, 2025 - 16:43 PDT

Update

We are continuing to work toward identifying the root cause of the Reltio Console UI issue.At this time, Console API services remain fully operational and are not impacted.
Our teams are actively monitoring the situation, and we will provide the next update within 30 minutes, or sooner if new information becomes available.
Posted Oct 18, 2025 - 16:21 PDT

Update

Our team is actively investigating the issue and working toward full restoration of the Console UI. At this time, Console API services remain fully operational. We will provide the next update within 30 minutes, or sooner if new information becomes available.
Posted Oct 18, 2025 - 15:52 PDT

Investigating

As of 5:25 pm EST, we are currently investigating a partial outage affecting the Reltio Console UI. Some users may experience intermittent issues accessing or loading the console interface. No impact has been observed on Reltio API calls or backend functionality — all integrations and API-driven operations remain fully operational.

Next Update:
Our team is actively working to identify the root cause and restore full UI functionality. Updates will be provided in 30 minutes as new information becomes available
Posted Oct 18, 2025 - 15:16 PDT
This incident affected: Global Tenant Application Console.