Reltio Multiple services impacted due to AWS outage

Incident Report for Reltio

Resolved

Reltio services were impacted by a global AWS outage that began on October 20 at 12:51 AM PDT in the US-EAST-1 region. The issue originated within AWS infrastructure, and the recovery of Reltio services depended on the restoration of AWS systems.
As of now, all Reltio tenants and services are fully restored and operational, and our teams are continuously monitoring for stability.
Posted Oct 20, 2025 - 07:32 PDT

Update

Reltio services were impacted by a global AWS outage that began on October 20 at 12:51 AM PDT in the US-EAST-1 region. The issue originated within AWS infrastructure, and recovery of Reltio services has been dependent on the restoration of AWS systems.
As of now, all Reltio tenants and services are operational, and most AWS services have recovered, allowing Reltio operations to resume normally.
However, AWS continues to report elevated error rates for certain operations — specifically for launching new EC2 instances or services that depend on EC2 (such as ECS).
Our teams are actively monitoring the situation and working closely with AWS to ensure full stability. We will continue to provide updates as AWS completes their recovery.
For the latest information, please check the AWS Status Page:
🔗 https://health.aws.amazon.com/health/status
We are currently monitoring service stability and will provide updates once full recovery is achieved.
Posted Oct 20, 2025 - 06:51 PDT

Monitoring

Reltio services were impacted by a global AWS outage that began on October 20 at 12:51 AM PDT in the US-EAST-1 region. The issue originated within AWS infrastructure, and recovery of Reltio services has been dependent on the restoration of AWS systems.
As of now, all Reltio tenants and services are operational, and most AWS services have recovered, allowing Reltio operations to resume normally.
However, AWS continues to report elevated error rates for certain operations — specifically for launching new EC2 instances or services that depend on EC2 (such as ECS) — within the US-EAST-1 region. This is causing slower recovery for Reltio services.
Our teams are actively monitoring the situation and working closely with AWS to ensure full stability. We will continue to provide updates as AWS completes their recovery.
For the latest information, please check the AWS Status Page:
🔗 https://health.aws.amazon.com/health/status
We are currently monitoring service stability and will provide updates once full recovery is achieved.
Posted Oct 20, 2025 - 04:49 PDT

Update

Reltio services experienced multiple impacts due to a global AWS outage that began on Oct 20 at 12:51 AM PDT. Services are now under recovery. Our teams are actively monitoring the situation and working closely with AWS.
For the latest updates, please check the AWS Status Page:
🔗 https://health.aws.amazon.com/health/status
We’ll continue to share updates as the situation progresses.
Posted Oct 20, 2025 - 03:27 PDT

Identified

Reltio services are currently experiencing multiple impacts due to a global AWS outage that began on Oct 20 at 12:51 AM PDT.
Our teams are actively monitoring the situation and working closely with AWS.
AWS identified a potential root cause at 2:01 AM PDT and continues to work toward resolution.
For the latest information, please check the AWS Status Page below:
🔗 https://health.aws.amazon.com/health/status
We’ll continue to share updates as the situation progresses.
Posted Oct 20, 2025 - 02:25 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 01:23 PDT

Investigating

Reltio services are currently experiencing multiple impacts due to a global AWS outage that started on Oct 20 at 12:51 AM PDT.
Our teams are actively monitoring the situation and working closely with AWS for further updates.
For the latest information, please check the AWS Status Page below:
🔗 https://health.aws.amazon.com/health/status
We’ll continue to share updates as the situation progresses.
Posted Oct 20, 2025 - 01:21 PDT
This incident affected: US Cloud (UI, Dataload, Export, Search, Queues, Reltio Integration Hub, Reference Data Management (RDM) Service, Authentication Service).