Reltio Multiple services impacted due to AWS outage

Incident Report for Reltio

Resolved

Greetings All,

At approximately 21:48UTC (2:48 PM PDT) on October 20, Reltio services in the US-EAST-1 region are fully functional and the services are operating normally.

Regards,
The Reltio Team
Posted Oct 20, 2025 - 15:13 PDT

Update

Greetings All,

Per AWS, at approximately 19:15 UTC (12:15 PM PDT) on October 20, they reported continued recovery across AWS services. Instance launches are succeeding across multiple Availability Zones in the us-east-1 region. They have lowered the severity to "Impacted" from "Degraded." AWS has noted some potential issues with Lambda usage.

Our team is closely monitoring the service to ensure stability and normal operations.

Thank you for your continued patience.

Regards,
The Reltio Team
Posted Oct 20, 2025 - 13:02 PDT

Monitoring

Reltio services were impacted by a global AWS outage that began on October 20 at 12:51 AM PDT in the US-EAST-1 region. The issue originated within AWS infrastructure, and recovery of Reltio services has been dependent on the restoration of AWS systems.
As of now, all Reltio tenants and services are operational, and most AWS services have recovered, allowing Reltio operations to resume normally.

For the latest information, please check the AWS Status Page:
🔗 https://health.aws.amazon.com/health/status
We are currently monitoring service stability and will provide updates once full recovery is achieved.
Posted Oct 20, 2025 - 10:38 PDT
This incident affected: US Cloud (UI, API, Dataload, Data Storage, Export, Search, Queues, Activity Log, Matching Service, Workflow API, SFDC Connector Service, Reltio Integration Hub, Reltio Data Pipelines, D&B Connector, Life Cycle Actions, Reference Data Management (RDM) Service, Reltio Intelligent Assistant (RIA) Service, Record ID Generator, Authentication Service).