Global Cleanse - Impact to Canada address verification
Incident Report for Reltio
Resolved
Our engineers have confirmed there are no further issues and the incident is now completely resolved.
Posted Mar 10, 2022 - 10:21 PST
Monitoring
Our engineers have implemented the fix and are monitoring the results.
Posted Mar 10, 2022 - 09:27 PST
Update
Our engineers have confirmed this is impacting only a small subset of users and are working on implementing a fix.

We will keep you posted on the progress.
Posted Mar 10, 2022 - 06:52 PST
Identified
Our engineers have identified the problem and are working on implementing a fix.
Posted Mar 10, 2022 - 05:22 PST
Update
We are continuing to investigate the issue.
Posted Mar 10, 2022 - 04:43 PST
Investigating
Our engineers are currently investigating an issue where few of our users may experience degradation when using the Cleanse process to verify Canada addresses.
Posted Mar 10, 2022 - 03:41 PST
This incident affected: Global Cleanse.